Evo/Lution BUGS

BUGS

 

 ladybird family

 Please Report Bugs Here

.

 

This entry was posted in Evolution and tagged , , , , , , . Bookmark the permalink.

17 Responses to Evo/Lution BUGS

  1. Pingback: Anonymous

  2. Pingback: Arch Linux GUI Installer Ready For Testing

  3. Jeff says:

    Fixed Feb 15 2014

    known bug: The installer will install Gnome even though the OS selector starts out on xfce

    workaround: Move the selector up, down, then back to xfce to install xfce

  4. Jeff says:

    Open Feb 16 2014 known bug Gnome install:

    terminal has both font and background set to black

    workaround: open the terminal, select edit>profile preferences>colors (tab) uncheck “use colors from system ”

  5. Jeff says:

    Fixed Feb 24 2014 Fu-rch-0.9b now boots into xfce desktop without user input.

    Upon starting the live DVD, you will see a command prompt as below
    root@archiso~ # Type, startxfce4 as below, then hit enter
    root@archiso~ #startxfce4 This will start the xfce desktop

  6. lee says:

    I found a bug in the installer. On the “Installation Type” menu I selected “Choose exactly where Arch should be installed. (advanced)”. Then I clicked forward. I got this error.

    Traceback (most recent call last):
    File “/usr/share/cnchi/cnchi.py”, line 311, in on_forward_button_clicked
    self.current_page.prepare(‘forwards’)
    File “/usr/share/cnchi/src/installation_advanced.py”, line 1165, in prepare
    self.fill_partition_list()
    File “/usr/share/cnchi/src/installation_advanced.py”, line 503, in fill_partition_list
    used = self.get_size(used_space.get_used_space(partition_path, fs_type) * p.geometry.length, dev.sectorSize)
    File “/usr/share/cnchi/src/parted/used_space.py”, line 213, in get_used_space
    space = get_used_btrfs(part)
    File “/usr/share/cnchi/src/misc.py”, line 163, in helper
    return func(*args, **kwargs)
    File “/usr/share/cnchi/src/parted/used_space.py”, line 154, in get_used_btrfs
    vsize = float(vsize[:-2])
    ValueError: could not convert string to float: ’292.97G’

    So I printed out vsize and usize:
    ’292.97GiB’
    ’292.97GiB’

    I saw several line of code that wouldn’t work with the “GiB”, so I worked on it a bit around line 154 of “/usr/share/cnchi/src/parted/used_space.py”. Sorry, I didn’t keep track of it and make a patch file.

    vunits = vsize[-3:]
    vsize = float(vsize[:-3])
    uunits = usize[-3:]
    usize = float(usize[:-3])
    if vunits == ‘MiB’:
    vmult = 1000000
    elif vunits == ‘GiB’:
    vmult = 1000000000
    elif vunits == ‘KiB’:
    vmult = 1000
    if uunits == ‘MiB’:
    umult = 1000000
    elif uunits == ‘GiB’:
    umult = 1000000000
    elif uunits == ‘KiB’:
    umult = 1000

    Then the installer worked fine.

    • Jeff says:

      Thank you,

      I’m very impressed with this Lee. Would you be interested in participating in the Evolution Linux Project? We could really use your talents.

      • Jeff says:

        Lee, sent you an email … and I’m getting similar errors with the new Evo build. I edited the file “/usr/share/cnchi/src/parted/used_space.py” per your suggestion below, then got the following errors.

        vsize, usize = (1, 0)
        x = x.decode()
        y = x.split(‘\n’)
        for z in y:
        if part in z:
        vsize = z.split()[3]
        usize = z.split()[5]
        vunits = vsize[-3:]
        vsize = float(vsize[:-3])
        uunits = usize[-3:]
        usize = float(usize[:-3])
        if vunits == ‘MiB’:
        vmult = 1000000
        elif vunits == ‘GiB’:
        vmult = 1000000000
        elif vunits == ‘KiB’:
        vmult = 1000
        if uunits == ‘MiB’:
        umult = 1000000
        elif uunits == ‘GiB’:
        umult = 1000000000
        elif uunits == ‘KiB’:
        umult = 1000
        usize = usize * umult
        vsize = vsize * umult
        used = usize/vsize
        return used

        ===================================================================
        ### errors ###
        ===================================================================

        [root@archiso furch]# cnchi
        pm2ml not found. Aria2 download won’t work.

        (cnchi.py:1458): Gtk-WARNING **: Theme parsing error: gtk.css:67:18: Not using units is deprecated. Assuming ‘px’.

        (cnchi.py:1458): Gtk-WARNING **: Theme parsing error: gtk.css:67:20: Not using units is deprecated. Assuming ‘px’.
        [root@archiso furch]# cnchi
        pm2ml not found. Aria2 download won’t work.

        (cnchi.py:1460): Gtk-WARNING **: Theme parsing error: gtk.css:67:18: Not using units is deprecated. Assuming ‘px’.

        (cnchi.py:1460): Gtk-WARNING **: Theme parsing error: gtk.css:67:20: Not using units is deprecated. Assuming ‘px’.
        Traceback (most recent call last):
        File “/usr/share/cnchi/cnchi.py”, line 311, in on_forward_button_clicked
        self.current_page.prepare(‘forwards’)
        File “/usr/share/cnchi/src/installation_advanced.py”, line 1163, in prepare
        self.fill_grub_device_entry()
        File “/usr/share/cnchi/src/installation_advanced.py”, line 224, in fill_grub_device_entry
        self.disks = pm.get_devices()
        File “/usr/share/cnchi/src/misc.py”, line 163, in helper
        return func(*args, **kwargs)
        File “/usr/share/cnchi/src/parted/partition_module.py”, line 50, in get_devices
        device_list = parted.getAllDevices()
        AttributeError: ‘module’ object has no attribute ‘getAllDevices’

        ===================================================================
        ### This is error above when selecting “chose exactly where … (advanced)” ###
        ### /usr/share/cnchi/src/parted/partition_module.py”, lines 45-57 below ###
        ===================================================================
        45 # Disk types
        46 DISK_EXTENDED = 1
        47
        58 @misc.raise_privileges
        49 def get_devices():
        50 device_list = parted.getAllDevices()
        51 disk_dic = {}
        52
        53 myhomepath = ‘/run/archiso/bootmnt’
        54 if os.path.exists(myhomepath):
        55 myhome = subprocess.check_output(["df", "-P", myhomepath]).decode()
        56 else:
        57 myhome = “”

        ===================================================================
        #### pushed back button to select the other option ###
        ===================================================================

        (cnchi.py:1460): Gtk-CRITICAL **: gtk_container_remove: assertion ‘gtk_widget_get_parent (widget) == GTK_WIDGET (container) || GTK_IS_ASSISTANT (container)’ failed
        Traceback (most recent call last):
        File “/usr/share/cnchi/cnchi.py”, line 311, in on_forward_button_clicked
        self.current_page.prepare(‘forwards’)
        File “/usr/share/cnchi/src/installation_automatic.py”, line 137, in prepare
        self.populate_devices()
        File “/usr/share/cnchi/src/misc.py”, line 163, in helper
        return func(*args, **kwargs)
        File “/usr/share/cnchi/src/installation_automatic.py”, line 106, in populate_devices
        device_list = parted.getAllDevices()
        AttributeError: ‘module’ object has no attribute ‘getAllDevices’

        ===================================================================
        ### This is error above when selecting “erase disk and install arch” ###
        ### /usr/share/cnchi/src/installation_automatic.py”, lines 104-106 below ###
        ===================================================================

        @misc.raise_privileges
        def populate_devices(self):
        device_list = parted.getAllDevices()

        • Jeff says:

          A good example of having the blinders on and focusing in the wrong area!

          Lesson learned, don’t forget to consider the simple things…..

          Rebuilt py3parted package against updated libraries, installed in my build repo, VIOLA!

          Problem solved.

  7. lee says:

    Please add xf86-input-synaptics (for touchpad support) and xf86-input-vmmouse (for better vm support) in the next release.

    Thank You

  8. R says:

    When booting the bootloader can’t locate the kernel image

  9. sp1d3rmxn says:

    As R stated it’s not booting at all. I tried 3 different methods on different mediums. The methods were:
    1) unetbootin the ISO to USB
    2) burned to CD
    3) dd to USB

    ALL attempts regardless of the hardware used gave the exact same error immediately upon pressing enter from the grub boot menu:
    “file not found” which quickly flashes and you see “.linux boot/vmlinuz” etc. I tried this on 2 laptops one has a pentium M chipset the other a duo core and also one desktop from the pentium4 days. Again all gave the same error everytime.

    I attempted to edit the boot menu and out the “/” before boot, however that made no difference. This is happening on Evo QT also in addition to the 0.9-11 release.

  10. Xmetal says:

    This is the same problem I have been having, since discovering your project via Spatry’s video. I changed the path in virualbox and via burnt DVD. I opened the ISO and I changed the path to the kernel (minor change) though as soon I try to boot that, it gives (again sorry, i do not know the exact message) that “inproper kernel for your hardware, please use the correct kernel for your hardware” type of a message.

    I was going to mention this before, though it seemed I was the only one having the issue, based on many reviews working perfect. Here, I can just say I am having the same issue as the last two posters. If somehow I find out its something on my end I am doing wrong, I will be glad to mention it for others as though I dont mind installing “the arch way” .. This project of yours looks like a GREAT idea, for arch installs.

    Thank you for your hard work and I hope someone can find out why some of us users are having this issue

    -Xmetalfanx

  11. Xmetal says:

    Ok, I tried the .92 QT ISO on a CD and while I still have the mentioned on my 64bit (from 2009) Toshiba … IT DOES boot now on my old @2007 32bit Desktop and I (at no fault to the prior OS on one of my Ext4) am installing now. I know how to install the “arch way” though I really wanted to run your installer through a full install.

    Again Thank you for your work
    -Xmetalfanx

  12. Jeff says:

    Announcement April 14, 2014: It was discovered the Evo-0.9-12.iso media was corrupt. Please see announcement here: http://www.jeffstory.org/wordpress/?p=1345

    The version, 0.9-12 was re-uploaded to SourceForge as Evo-0.9-12a.iso (notice the a).
    This version has been verified as correct by having the proper md5sum after uploading, and downloading it from SourceForge to re-verify via testing.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre lang="" line="" escaped="" cssfile="">